Skip to content
On this page

v3.0 升级指南

配置文件调整

v3.0 版本由于支持了多租户,所以配置文件有所调整。

请参考 初始化 调整您的配置文件。

初始化方式调整(非必须,但推荐)

此项非必须,但是强烈推荐您更改调整

同样参考 初始化方式一 调整您的配置初始化。

更改版本号

将 composer.json 的 yansongda/pay 版本号更改为 ~3.0.0,随后 composer update 即可。

break-change

发布说明

微信API问题

v3.0 版本开始,Pay 使用微信 v3.0 API,因此, v3.0 API 中不支持的操作,Pay v3.0 也不会支持,可以参考微信支付官方文档或 https://github.com/yansongda/pay/issues/473

如果你强依赖微信支付中 v2 版本的API,建议保持 Pay v2 版本不做升级操作

Released under the MIT License.